Sistem de monitorizare a unui UPS

Dispozitivele de tip UPS (Uninterruptible Power Supply) asigură protecție pentru sistemele electronice împotriva variațiilor de tensiune ale rețelelor de alimentare și împotriva căderilor de tensiune permițând funcționarea continuă. În cazul căderilor de tensiune de scurtă durată sistemele nu își vor întrerupe funcționarea dar în cazul căderilor de mai mare durată sistemele electronice, mai ales sistemele de calcul și dispozitivele de stocare a datelor, trebuie închise în siguranță fără a exista pericolul defectării sau pierderilor de date. Procesul de închidere controlat se poate face de către utilizator, dacă este prezent, sau în mod automat dacă sistemul UPS are capabilitatea de a semnaliza căderea tensiunii de alimentare. În cadrul materialului de față ne propunem să prezentăm implementarea unui sistem de monitorizare a funcționării unui dispozitiv UPS care să permită închiderea automată, în siguranță, a sistemelor de calcul.

Pentru implementare vom utiliza o placă de dezvoltare Raspberry Pi Zero W (se poate utiliza și o placă Raspberry Pi 3) ce va comunica cu dispozitivul UPS printr-o conexiune USB. Se pot monitoriza orice dispozitive UPS care au facilitatea de raportare printr-o astfel de conexiune. În teste s-a utilizat un dispozitiv UPS APC Back-UPS ES550. Pentru conectarea la placa Raspberry Pi Zero W este necesar un adaptor OTG USB.

2

Ca sistem de operare pentru placa de dezvoltare Raspberry Pi Zero W a fost folosită versiunea Lite a sistemului de operare Raspbian, mai exact Raspbian Stretch Lite 2018-06-27. După copierea imaginii pe cardul microSD se recomandă configurarea pentru accesul la distanță înainte de pornirea plăcii de dezvoltare, a se vedea și „Raspberry Pi Zero Headless Quick Start”:

  • Se creează un fișier gol cu numele ssh pentru a activa conectarea de la distanță;
  • Se creează un fișier conf pentru conectarea la rețea cu următorul conținut:

    ctrl_interface=DIR=/var/run/wpa_supplicant

   GROUP=netdev

   update_config=1

   network={

        ssid=”YOURSSID”

        psk=”YOURPASSWORD”

        scan_ssid=1

    }

După pornirea sistemului și conectarea UPS-ului la placa de dezvoltare putem verifica conexiunea cu ajutorul comenzii:

# lsusb

3

Dacă totul este în regulă vom trece la instalarea pachetelor necesare supravegherii dispozitivului UPS:

# sudo apt-get update

# sudo apt-get upgrade (recomandat)

# sudo apt-get install apcupsd

Pentru mai multe informații asupra programului APC UPS Daemon puteți consulta manualul oficial. Înainte de utilizare trebuie să efectuăm câteva modificări în fișierul de configurare /etc/apcupsd/apcupsd.conf:

UPSNAME MyAPC

UPSCABLE usb

USBTYPE usb

DEVICE

și în fișierul /etc/default/apcupsd:

ISCONFIGURED=yes

Finalmente putem repornim serviciul:

# sudo apcupsd restart

Testarea comunicației cu dispozitivul UPS se va face cu ajutorul comenzii:

# apcaccess status

4

Supravegherea se poate face și prin intermediul unei interfețe web. Pentru acest lucru vom instala serverul web apache și componenta cgi a APC UPS Daemon:

# sudo apt-get install apache2 apcupsd-cgi

Pentru a activa execuția fișierelor cgi la nivel de server web este necesară realizarea unei legături simbolice la nivelul fișierelor de configurare apache:

# cd /etc/apache2/mods-enabled

# sudo ln -s ../mods-available/cgi.load

# sudo /etc/init.d/apache2 restart

Interfața web poate fi accesată la adresa:

http://YOUR_RPi_IP/cgi-bin/apcupsd/multimon.cgi

5

6

În fișierul de configurare /etc/apcupsd/apcupsd.conf putem personaliza diverși parametrii (precum procentul din baterie la care sistemul să se oprească automat, timpul de funcționare pe baterie):

ONBATTERYDELAY 6

BATTERYLEVEL 5

MINUTES 3

În mod implicit la apariția evenimentelor de cădere a alimentării și la revenirea alimentării serviciul APC UPS Daemon rulează scripturile /etc/apcupsd/onbattery și /etc/apcupsd/offbattery. Acestea pot fi personalizate pentru a efectua diverse operații dorite (să trimită email, să oprească automat alte sisteme de calcul etc.).

Pentru mai multe informații puteți consulta și proiectele:

Și ca o alternativă la software-ul de monitorizare:

Sistemul de monitorizare este capabil să comande oprirea în siguranță a mai multor sisteme de calcul inclusiv sisteme ce rulează sisteme de operare Microsoft Windows – a se vede materialul: „How to Remotely Shut Down or Restart Windows PCs”.

Router WiFi GSM utilizând Raspberry PI Zero W

Plăcile de dezvoltare Raspberry PI sunt cunoscute pentru ușurința cu care se poate implementa un router / gateway TCP/IP grație sistemului de operare Linux ce rulează pe aceste plăci. Placa Raspberry PI 3 ce integrează o interfață de rețea WiFi (pe lângă interfața ethernet clasică) poate sta la baza unui AP WiFi printr-o configurare foarte simplă (a se vedea „Cum putem utiliza placa Raspberry Pi ca Access Point WiFi?”). Chiar dacă implementarea unor astfel de dispozitive (router, gateway sau AP) poate părea la prima vedere doar un exercițiu educațional având în vedere multitudinea de dispozitive comerciale cu aceste funcționalități, realizarea unui sistem de control al comunicațiilor personalizat poate permite implementarea unor funcționalități proprii inedite și de multe ori un cost mai mic decât al dispozitivelor comerciale.

Placa de dezvoltare Raspberry PI Zero W este un membru mai nou al familiei de plăci Raspberry introducând un format mai mic al plăcii și un cost mult mai mic dar fiind limitată din punct de vedere al puterii de calcul și al memorie și neavând interfață de rețea ethernet (doar WiFi). La prima vedere această placă nu am putea să o utilizăm la implementarea unui sistem de tip router având o singură interfață de rețea. Având în vedere dimensiunea, costul și consumul mult mai mici decât al unei plăci Raspberry PI 3 este totuși o alegere foarte bună pentru implementarea unui router WiFi GSM. Pentru aceste lucru avem nevoie de un modem USB GSM (în cadrul testelor s-a utilizat un modem Huawei E3131 dar se poate utiliza orice modem USB GSM, de exemplu). Conectarea modemului la placa de dezvoltare necesită un adaptor microUSB – USB. Bineînțeles, pentru funcționarea sistemului sunt necesare un card microSD pentru sistemul de operare și un alimentator de 5V, 1A.

Punerea în funcțiune a unei plăci Raspberry PI Zero este o provocare din cauza numărului mic de porturi USB. Recomandăm utilizarea unui cablu serial de debug pentru a interacționa mai ușor cu placa de dezvoltare (a se vedea și materialul „Raspberry Pi Zero Headless Quick Start”). Ca sistem de operare vom utiliza Raspbian Lite pentru a nu încărca procesorul plăcii de dezvoltare cu servicii și pachete software inutile (testele au fost realizate utilizând versiunea 2018-03-13-raspbian-stretch-lite).

Chiar dacă în final conexiunea la Internet a sistemului se va face prin intermediul conexiunii modemului USB GSM, pentru a instala pachetele necesare este nevoie să activăm temporar conexiunea WiFi a plăcii de dezvoltare pentru acces la Internet. Astfel în fișierul /etc/wpa_supplicant/wpa_supplicant.conf vom adăuga liniile cu datele de acces la rețeaua WiFi locală (aceste linii vor fi șterse după realizarea configurării de AP):

network={

 ssid=”…”

 psk=”…”

}

Configurarea WiFi se poate face și la nivel card de memorie înainte de prima pornire a sistemului – a se vedea materialul: „Manually setting up Pi WiFi using wpa_supplicant.conf”.

După repornirea sistemului vom instala update-urile sistemului de operare:

# sudo apt-get update

# sudo apt-get upgrade

și pachetele necesare necesare comunicației cu modemul GSM:

# sudo apt-get install ppp usb-modeswitch usb-modeswitch-data

După conectarea fizică a modemului și o nouă repornire a sistemului putem configura legătura de date GSM. În fișierul /etc/network/interfaces se vor adăuga următoarele linii:

auto gprs

iface gprs inet ppp

provider gprs

Ulterior vom crea fișierul gprs în directorul /etc/ppp/peers cu următorul conținut (cartela SIM utilizată nu avea activat codul PIN):

connect “/usr/sbin/chat -v -f /etc/chatscripts/gprs -T em”

/dev/ttyUSB0

noipdefault

defaultroute

replacedefaultroute

hide-password

noauth

persist

usepeerdns

După o nouă restartare conexiunea de date GSM va deveni funcțională și putem șterge configurația din fișierul /etc/wpa_supplicant/wpa_supplicant.conf și putem trece la configurația AP. Vom instala pachetele software necesare managementului clienților WiFi:

# sudo apt-get update

# sudo apt-get install dnsmasq hostapd

și vom opri pentru moment serviciile până după configurarea corectă a acestora:

# sudo systemctl stop dnsmasq

# sudo systemctl stop hostapd

Interfața de rețea WiFi va avea în configurația de AP adresă IP statică deci vom configura acest lucru în serviciul DHCP (fișierul /etc/dhcpcd.conf):

interface wlan0

    static ip_address=192.168.66.1/24

și vom reporni serviciul:

# sudo service dhcpcd restart

Având în vedere că funcționalitatea de AP necesită oferirea clienților WiFi de configurații dinamice de rețea este necesară configurarea serverului DHCP (dnsmasq). Vom crea un nou fișier de configurare:

# sudo mv /etc/dnsmasq.conf /etc/dnsmasq.conf.orig 

# sudo nano /etc/dnsmasq.conf

în care vom indica plaja de adrese IP oferite clienților WiFi:

interface=wlan0   

  dhcp-range=192.168.66.2,192.168.66.20,255.255.255.0,24h

În fișierul serviciului de management AP (/etc/hostapd/hostapd.conf) vom introduce următoarea configurație (personalizând, bineînțeles, datele de conectare la AP):

interface=wlan0

driver=nl80211

ssid=…

hw_mode=g

channel=7

wmm_enabled=0

macaddr_acl=0

auth_algs=1

ignore_broadcast_ssid=0

wpa=2

wpa_passphrase=…

wpa_key_mgmt=WPA-PSK

wpa_pairwise=TKIP

rsn_pairwise=CCMP

și vom referi fișierul în fișierul de configurare principal al serviciului hostapd (/etc/default/hostapd):

DAEMON_CONF=”/etc/hostapd/hostapd.conf”

După aceste configurări putem porni cele două servicii:

# sudo systemctl start hostapd

# sudo systemctl start dnsmasq

Pentru ca sistemul să retransmită pachetele din rețeaua WiFi în rețeua Internet este necesar să achivăm rutarea pachetelor TCP/IP – în fișierul /etc/sysctl.conf vom decomenta următoarea linie:

net.ipv4.ip_forward=1

Ultimul pas este configurarea serviciului de filtrare a pachetelor (iptables). Vom adăuga și salva o regulă de MASQUERADE:

sudo iptables -t nat -A  POSTROUTING -o ppp0 -j MASQUERADE

sudo sh -c “iptables-save > /etc/iptables.ipv4.nat”

și o vom executa la fiecare repornire a sistemului prin adăugarea următoarei linii în fișierul /etc/rc.local înainte de linia exit 0:

iptables-restore < /etc/iptables.ipv4.nat

După o ultimă repornire routerul WiFi GSM este funcțional.

Repetor WiFi cu legătură GSM de siguranță

Dispozitivele de tip repetor au ca principal scop extinderea acoperirii semnalului pentru o rețea radio. Repetoarele WiFi extind acoperirea unei rețele WiFi astfel încât să nu fie necesară instalarea și managementul mai multor dispozitive de tip AP. În cadrul materialului de față vă propunem implementarea unui dispozitiv repetor WiFi cu o funcționalitate suplimentară față de un repetor standard: dirijarea traficului pe o conexiune de date GSM în cazul în care conexiunea WiFi se întrerupe. Astfel, sistemul se va comporta ca un repetor WiFi în mod obișnuit dar se va transforma într-un router WiFi GSM în cazul în care conexiunea principală are probleme (a se vedea și materialul „Router WiFi GSM utilizând LinkIt Smart 7688”).

Pentru implementare vom utiliza o placă de dezvoltare LinkIt Smart 7688 bazată pe circuitul SoC MediaTek MT7688AN și care rulează distribuția Linux OpenWRT. Această placă de dezvoltare oferă, la un preț redus, toate facilitățile de routare, filtrare și control al traficului TCP/IP oferite de sistemele de operare Linux. Pentru mai multe detalii legate de funcționarea și utilizarea plăcii de dezvoltare LinkIt Smart 7688 puteți consulta wiki-ul oficial. Pentru conexiunea de date GSM vom utiliza un modem USB GSM 3G. Conectarea modemului USB la placa de dezvoltare necesită un adaptor microUSB – USB. Alimentarea sistemului se va face la 5V, minim 500mA – preferabil 1A (orice încărcător de mobil de 1A și mufă microUSB e bun).

2

Placa de dezvoltare LinkIt Smart 7688 oferă posibilitatea de funcționare în mod repetor începând cu versiunea 0.9.4 de firmware. Nu vom utiliza modalitatea de configurare oferită de interfața web, configurarea inițială va fi de Station mode (client WiFi) deoarece vom avea nevoie de conexiunea Internet pentru a instala câteva pachete software suplimentare.

3

După configurarea și repornirea plăcii ne putem conecta la aceasta prin SSH (utilizând PUTTY de exemplu). IP-ul de conectare depinde de rețeaua locală. Vom rula următoarele comenzi pentru instalarea pachetelor software necesare configurării conexiunii de date GSM:

# opkg update

# opkg install comgt kmod-usb-serial kmod-usb-serial-option kmod-usb-serial-wwan usb-modeswitch usbtools

Eventual putem instala și un editor de text suplimentar dacă nu ne place vi :

# opkg install nano

Sistemul va avea două configurații diferite de rețea între care va comuta în cazul întreruperii / restaurării conexiunii WiFi principale. Vom crea în directorul /root două directoare config_wifi și config_3g și în fiecare vom crea 3 fișiere de configurare: firewall, network și wireless (se pot copia din /etc/config pentru a nu le tasta de la zero).

Fișierul network – varianta wifi – nu definește nici o interfață utilizată în funcționalitatea de repetor.

config interface ‘loopback’

option ifname ‘lo’

option proto ‘static’

option ipaddr ‘127.0.0.1’

option netmask ‘255.0.0.0’

config globals ‘globals’

option ula_prefix ‘fdea:6296:e400::/48’

config interface ‘lan’

option force_link ‘1’

option macaddr ‘9c:65:f9:1e:69:77’

option proto ‘static’

option netmask ‘255.255.255.0’

option ip6assign ’60’

option ipaddr ‘192.168.100.1’

option delegate ‘0’

option ifname ‘ra0’

config switch

option name ‘switch0’

option reset ‘1’

option enable_vlan ‘0’

config interface ‘wan’

option proto ‘dhcp’

Fișierul network – varianta 3G – va arăta identic dar va avea în plus definiția interfeței de comunicație GSM (se va adăuga la sfârșitul fișierului anterior). APN-ul și codul pin se vor personaliza în funcție de cartela SIM GSM.

config interface ‘gsm’

option proto ‘3g’

option device ‘/dev/ttyUSB0’

option service ‘umts’

option apn ‘net’

option pincode ‘0000’

Fișierul wireless – varianta WiFi – va defini funcționarea în mod mixt AP+STA. În fișier trebuie personalizate datele de acces la rețeaua WiFi (secțiunea STA) și datele de conectare la repetor (secțiunea AP) – pot fi identice, repetorul poate oferi acces cu aceleași credențiale ca și rețeaua WiFi originală.

config wifi-device ‘radio0’

option type ‘ralink’

option variant ‘mt7628’

option country ‘TW’

option hwmode ’11g’

option htmode ‘HT40’

option channel ‘auto’

option disabled ‘0’

option linkit_mode ‘apsta’

config wifi-iface ‘ap’

option device ‘radio0’

option mode ‘ap’

option network ‘lan’

option ifname ‘ra0’

option encryption ‘psk2’

option seq ‘1’

option ssid ‘xxxxxx’

option key ‘xxxxxx’

config wifi-iface ‘sta’

option device ‘radio0’

option mode ‘sta’

option network ‘wan’

option ifname ‘apcli0’

option led ‘mediatek:orange:wifi’

option ssid ‘xxxxx’

option key ‘xxxxx’

option encryption ‘psk2’

Fișierul wireless – varianta 3G  – va defini funcționarea doar în mod AP. În cazul în care definim aceleași credențiale ca și AP-ul principal, sistemul va suplini conexiunea WiFi și pentru clienții direcți ai AP-ului principal în cazul întreruperii conexiunii principale.

config wifi-device ‘radio0’

option type ‘ralink’

option variant ‘mt7628’

option country ‘TW’

option hwmode ’11g’

option htmode ‘HT40’

option channel ‘auto’

option disabled ‘0’

option linkit_mode ‘ap’

config wifi-iface ‘ap’

option device ‘radio0’

option mode ‘ap’

option network ‘lan’

option ifname ‘ra0’

option encryption ‘psk2’

option seq ‘1’

option ssid ‘xxxxxx’

option key ‘xxxxxx’

Fișierul firewall – variantele WiFi și 3G diferă de fișierul original din /etc/config doar prin linia option network a secțiunii wan.

———————————- WiFi ——————————-

config zone

option name ‘wan’

option network ‘wan wan6’

option output ‘ACCEPT’

option forward ‘REJECT’

option masq ‘1’

option mtu_fix ‘1’

option input ‘ACCEPT’

———————————- 3G ——————————-

config zone

option name ‘wan’

option network ‘gsm’

option output ‘ACCEPT’

option forward ‘REJECT’

option masq ‘1’

option mtu_fix ‘1’

option input ‘ACCEPT’

Scripturile care vor face comutarea între cele două configurații de rețea (între cele două funcționalități ale sistemului) se vor crea în directorul /root sub denumirile: switch și normal (nu uitați să dați drepturi de execuție pe cele două fișiere # chmod +x …). Fișierul switch va face comutarea pe conexiunea GSM în cazul în sistemul nu are conexiune la Internet:

#!/bin/ash

ping -q -c 1 -W 10 8.8.8.8 > /dev/null

if [ $? -ne 0 ]

then

cp -f /root/config_3g/network /etc/config/network

cp -f /root/config_3g/firewall

/etc/config/firewall

cp -f /root/config_3g/wireless

/etc/config/wireless

/etc/init.d/network restart

fi

Scriptul normal va verifica dacă este în modul GSM (prin verificarea conexiunii cu AP-ul principal – scriptul trebuie personalizat cu adresa IP a AP-ului principal) și va reîncerca reintrarea în mod repetor WiFi:

#!/bin/ash

ping -q -c 1 -W 10 XXX.XXX.XXX.XXX > /dev/null

if [ $? -ne 0 ]

then

cp -f /root/config_wifi/network

/etc/config/network

cp -f /root/config_wifi/firewall

/etc/config/firewall

cp -f /root/config_wifi/wireless

/etc/config/wireless

/etc/init.d/network restart

fi

Ambele scripturi vor fi rulate în mod automat de serviciul cron al sistemului de operare. Frecevența de execuție stă la latitudinea utilizatorului, testele au fost realizate cu o frecvență de o dată pe oră (la fix scriptul switch, la și jumătate scriptul normal), conținutul fișierului /etc/crontabs/root fiind:

00 * * * * /root/switch

30 * * * * /root/normal

Sistemul prezentat poate fi folosit în diverse scenarii, de exemplu:

  • Într-o locuință de dimensiuni mari pentru a extinde semnalul WiFi în toate camerele și pentru a oferi o conexiune de siguranță la Internet pentru cazurile de întrerupere a conexiunii principale. În acest caz credențialele de acces pot fi comune între AP-ul principal și repetor.
  • Pentru o rețea de senzori WiFi se poate oferi o rețea WiFi dedicată, eventual o zonă de acoperire specială utilizând o antenă direcțională, și care are legătură la Internet redundantă (ISP / GSM) având în vedere un posibil caracter critic a funcționalității.

Router WiFi GSM utilizând LinkIt Smart 7688 Duo

Chiar dacă implementarea funcționalității de router WiFi GSM utilizând familia de plăci LinkIt Smart 7688 nu este nouă în cadrul lecțiilor noastre, o să încercăm în materialul de față să propunem o versiune îmbunătățită a acestui tip de sistem. Placa de dezvoltare LinkIt Smart 7688 Duo, spre deosebire de placa LinkIt Smart 7688, deține un microcontroler ATmega32U4 ce poate fi utilizat în cadrul sistemului pentru diverse sarcini de timp real (comandă de motoare, interfață utilizator, achiziție de valori de la diverși senzori etc.). În cadrul sistemului nostru vom utiliza microcontrolerul prezent pe placa de dezvoltare pentru implementarea interfeței utilizator, mai exact vom adăuga sistemului un ecran ce va afișa în timp real date despre funcționarea routerului (număr de clienți WiFi, puterea semnalului GSM, traficul prin intermediul routerului).

Pentru configurarea de bază a routerului se vor efectua exact aceeași pași ca și în cazul plăcii LinkIt Smart 7688 (a se vedea și „Router WiFi GSM utilizând LinkIt Smart 7688”), mai exact (pe scurt):

  • Vom configura placa în mod client WiFi pentru a putea instala pachetele necesare funcționării modemului GSM;
  • Vom instala și configura modemul GSM prin definirea unei noi interfețe de rețea;
  • Noua interfață de rețea va fi introdusă în firewall în zoua wan și vom configura pornirea automată a interfeței la pornirea sistemului de operare;
  • Vom reconfigura placa în modul AP setând numele și parola de acces dorită.

Pentru afișare vom utiliza un ecran OLED monocrom ce va comunica cu placa de dezvoltare prin I2C:

  • Alimentarea se va face la 3.3V (3.3V conectat la 3.3V, GND la GND);
  • Pinul Data al afișajului la pinul D2 (SDA) al plăcii de dezvoltare;
  • Pinul Clk al afișajului la pinul D3 (SCL) al plăcii de dezvoltare;
  • Pinul Rst al afișajului la pinul D5 al plăcii de dezvoltare (opțional).

2

Programul (pentru microcontrolerul ATmega32U4) va utiliza bibliotecile Adafruit GFX și Adafruit SSD1306 pentru partea de comunicație cu ecranul OLED și biblioteca Process (Bridge) pentru a comunica cu sistemul de operare OpenWRT.

#include <SPI.h>

#include <Wire.h>

#include <Adafruit_GFX.h>

#include <Adafruit_SSD1306.h>

#define OLED_RESET 5

Adafruit_SSD1306 display(OLED_RESET);

#include <Process.h>

Secțiunea setup() va inițializa ecranul OLED și comunicația cu sistemul de operare OpenWRT. Ecranul va afișa mesajul Initializing… pâna la încărcarea și inițializarea sistemului de operare (funcția Bridge.begin() va bloca programul până la stabilirea comunicației cu sistemul de operare).

3

void setup() {

  display.begin(SSD1306_SWITCHCAPVCC, 0x3C);

  display.display();

  delay(2000);

  display.clearDisplay();

  display.setTextSize(1);

  display.setTextColor(WHITE);

  display.setCursor(0,0);

  display.println(“Initializing…”);

  display.display();

  delay(1);

  Bridge.begin();

  delay(1000);

}

Secțiunea loop() este responsabilă cu interogarea sistemului de operare și afișarea răspunsurilor pe ecranul OLED. Pe prima linie este afișată ora și data (utile pentru a verifica dacă sistemul funcționează corect, nu s-a blocat), a doua linie va afișa calitatea semnalului GSM (utilă pentru poziționarea unei antene externe), a treia linie va afișa numărul de clienți WiFi iar ultima linie cantitatea de informație (recepționată și transmisă) transferată prin intermediul conexiunii GSM (informații utile în cazul unui abonament de date cu limitări la datele transferate). Datele sunt împrospătate o dată la 30 de secunde.

4

void loop() {

  Process MyProc;

  display.clearDisplay();

  display.setTextSize(1);

  display.setTextColor(WHITE);

  display.setCursor(0,0);

  MyProc.runShellCommand(“date +%H:%M”);

  while (MyProc.available() > 0) {

    char c = MyProc.read();

  if (c!=’\n’) display.print((char)c);

  }

  display.print(” “);

  MyProc.runShellCommand(“date +%D”);

  while (MyProc.available() > 0) {

    char c = MyProc.read();

    if (c!=’\n’) display.print((char)c);

  }

  display.println();

  display.println();

  display.print(“RSSI:”);

  MyProc.runShellCommand(“/root/get_rssi”);

  while (MyProc.available() > 0) {

      char c = MyProc.read();

      if (c!=’\n’) display.print((char)c);

  }

  display.println();

  display.println();

  display.print(“Clients:”);

  MyProc.runShellCommand(“/root/clients”);

  while (MyProc.available() > 0) {

      char c = MyProc.read();

      if (c!=’\n’) display.print((char)c);

  }

  display.println();

  display.println();

  MyProc.runShellCommand(“ifconfig 3g-gsm | grep ‘RX bytes’ | awk ‘{ print $1 $3 $4 }'”);

  while (MyProc.available() > 0) {

    char c = MyProc.read();

    if (c!=’\n’) display.print((char)c);

  }

  display.println();

  MyProc.runShellCommand(“ifconfig 3g-gsm | grep ‘RX bytes’ | awk ‘{ print $5 $7 $8}'”);

  while (MyProc.available() > 0) {

    char c = MyProc.read();

    if (c!=’\n’) display.print((char)c);

  }

  display.display();

  delay(30000);

}

Este posibil ca legătura dintre microcontrolerul ATmega32U4 și sistemul de operare OpenWRT să fie oprită implicit (să fie oprit serviciul responsabil la nivel de sistem de operare). În acest caz este necesară rularea următoarelor comenzi în linia de comenzi a sistemului de operare:

# uci set yunbridge.config.disabled=’0’

# uci commit

# reboot

Pentru rularea scripturilor de interogare a puterii semnalului și a numărului de clienți este necesară instalarea pachetului bash sub sistemul de operare OpenWRT:

# opkg update

# opkh install bash

Scriptul de interogare a puterii semnalului se va salva în diretorul /root sub denumirea get_rssi (tebuie acordate permisiuni de execuție #chmod +x get_rssi). Scriptul va interpreta o valoare pentru calitatea semnalului mai mare de 25 ca fiind excelentă, între 19 și 25 bună, între 13 și 19 medie, între 7 și 13 slabă și sub 7 foarte slabă. Lipsa semnalului poate însemna atât aflarea într-o zonă fără semnal dar și o problemă cu modemul GSM (deconectat?) sau cu SIM-ul GSM (neintrodus, fără credit?).

#!/bin/bash

rssi=`printf “%s\n” $((/usr/sbin/chat -V -s ” ‘AT+CSQ’ ‘OK’ ” > /dev/ttyUSB2 < /dev/ttyUSB2) 2>&1 | /bin/grep CSQ: | /usr/bin/awk ‘{print $2}’)`

rssi=”${rssi//,/.}”

rssi=$(printf “%.0f” $rssi)

if [ $rssi -gt 25 ]; then

        echo “$rssi Excellent”

elif [ $rssi -gt 19 ] && [ $rssi -le 25 ]; then

        echo “$rssi Good”

elif [ $rssi -gt 13 ] && [ $rssi -le 19 ]; then

        echo “$rssi Average”

elif [ $rssi -gt 7 ] && [ $rssi -le 13 ]; then

        echo “$rssi Low”

elif [ $rssi -gt 0 ] && [ $rssi -le 7 ]; then

        echo “$rssi Very low”

else

        echo “No signal”

fi

Scriptul de interogare a numărului de clienți WiFi se va salva în diretorul /root sub denumirea clients (tebuie acordate permisiuni de execuție #chmod +x clients). Scriptul va verifica numărul de înregistrări ARP din rețeaua WiFi. Atenție!!! Conectarea unui nou client WiFi va conduce la incrementarea imediată a numărului de clienți dar deconectarea nu va conduce la o decrementare decât în momentul în care expiră cache-ul ARP.

nr=0

for ip in $(cat /proc/net/arp | grep -v IP | awk ‘{print

$1}’); do

    nr=$((nr+1))

done

echo $nr

 

Dacă doriți să explorați și alte variante de implementare puteți vedea și „Smart Router With WiFi Connection Visualization”.

Router WiFi GSM utilizând LinkIt Smart 7688

Asigurarea conexiunii la Internet în cazul absenței unei conexiuni terestre (prin cablu sau fibră optică) se poate face, bineînțeles, apelând la serviciile oferite de companiile de telefonie mobilă prin intermediul unei cartele SIM ce oferă transfer de pachete de date. Există multe opțiuni comerciale pentru implementarea acestei facilități de routare între o rețea de date WiFi și o rețea GSM: routere WiFi GSM, telefoane mobile ce funcționează ca AP (tethering) ș.a.m.d. dar majoritatea acestor soluții nu oferă o flexibilitate sau un control al conexiunilor foarte bune. Din acest motiv realizarea unui router „personalizat” se poate dovedi și o soluție mult mai ieftină și o metodă de a implementa mecanisme de filtrare, autentificare, control al conexiunilor mult mai sofisticate.

Pentru implementare vom utiliza o placă de dezvoltare LinkIt Smart 7688 bazată pe circuitul SoC MediaTek MT7688AN și care rulează distribuția Linux OpenWRT. Această placă de dezvoltare oferă, la un preț redus, toate facilitățile de routare, filtrare și control al traficului TCP/IP oferite de sistemele de operare Linux. Pentru mai multe detalii legate de funcționarea și utilizarea plăcii de dezvoltare LinkIt Smart 7688 puteți consulta wiki-ul oficial. Pentru conexiunea de date GSM vom utiliza un modem USB GSM – testele au fost realizate utilizând un modem Huawei E220 dar se poate utiliza orice alt modem USB GSM compatibil. Conectarea modemului USB la placa de dezvoltare necesită un adaptor microUSB – USB. Alimentarea sistemului se va face la 5V, minim 500mA – preferabil 1A (orice încărcător de mobil de 1A și mufă microUSB e bun).

2

La punere în funcțiune a plăcii de dezvoltare aceasta funcționează în mod AP. Ne vom conecta la AP-ul LinkIt_Smart_7688_XXXXXX și apoi la interfața de administrare web (IP 192.168.100.1).

3

La prima conectare se va stabili parola utilizatorului root (contul de administrare a sistemului de operare).

4

Pentru a putea instala pachetele software necesare funcționării modemului USB GSM vom configura placa de dezvoltare ca și client WiFi – Station Mode (pentru a avea conexiune Internet).

ATENȚIE!!! Placa de dezvoltare are definită implicit o interfață de rețea cu IP-ul 192.168.100.1 . Orice încercare de a introduce placa de dezvoltare într-o rețea ce oferă prin DHCP adrese IP în clasa 192.168.100.0/24 va eșua.

După configurarea și repornirea plăcii ne putem conecta la aceasta prin SSH (utilizând PUTTY de exemplu). IP-ul de conectare depinde de rețeaua locală. Vom rula următoarele comenzi pentru instalarea pachetelor software necesare configurării conexiunii de date GSM:

# opkg update

# opkg install comgt kmod-usb-serial kmod-usb-serial-option kmod-usb-serial-wwan usb-modeswitch

Eventual putem instala și un editor de text suplimentar dacă nu ne place vi :

# opkg install nano

Având conectat modemul USB GSM vom reporni placa de dezvoltare. Ne vom reconecta prin SSH și vom verifica dacă modemul este recunoscut de sistemul de operare în mod corect (vom rula comanda dmesg).

6

În cazul în care modemul este recunoscut corect de sistemul de operare vom regăsi în jurnalul de pornire a sistemului de operare (consultat anterior cu ajutorul comenzii dmesg) linii care indică instalarea modemului GSM ca dispozitiv specific USB (ttyUSB0 de exemplu). În cazul în care modemul este văzut ca alt tip de dispozitiv (de stocare în masă – memorie usb de exemplu) înseamnă că pachetul usb-modeswitch care se ocupă de autoconfigurarea modemului nu are în baza de date proprie modelul de modem utilizat. Este recomandat să căutăm un modem care să fie deja în baza de date a pachetului software. Configurarea manuală a modemului este destul de dificilă. Pentru mai multe informații se poate parcurge materialul „Use 3g/UMTS USB Dongle for WAN connection”.

Pentru a putea accesa Internetul prin intermediul modemului USB GSM este nevoie să avem o cartelă SIM funcțională (se poate testa prealabil modemul pe un sistem de calcul obișnuit) și să realizăm următoarele configurări în fișierele sistemului de operare. În fișierul /etc/config/network vom adăuga la final (pinul și APN-ul sunt specifice cartelei SIM utilizate):

config interface ‘gsm’

        option proto ‘3g’

        option service ‘umts’

        option device ‘/dev/ttyUSB0’

        option apn ‘net’

        option pincode ‘0000’

În fișierul /etc/config/firewall vom adăuga noua interfață de rețea în categoria wan :

config zone

        option name ‘wan’

        list network ‘gsm’

        …

Pentru ca intefața GSM să fie pornită automat după repornirea sistemului vom adăuga în fișierul /etc/rc.local linia ifup gsm (comanda de pornire a conexiunii GSM) înainte de linia exit 0 .

ifup gsm

exit 0

După finalizarea configurării conexiunii GSM (se poate reporni sistemul și verifica prin intermediul comenzii route dacă există conexiune Internet GSM) se va trece sistemul în configurație AP din interfața web de administrare (se va stabili numele și parola de acces pentru rețeaua WiFi).

7

După o ultimă repornire a sistemului routerul WiFi GSM este gata de utilizare. Acesta va oferi adrese în clasa 192.168.100.0/24 și vom putea accesa interfața de administrare prin intermediul adresei IP 192.168.100.1 . Pentru configurări avansate (firewall, port-forwarding) se poate accesa consola Luci specifică sistemului de operare OpenWRT (link în interfața de administrare, încercuit cu roșu în imaginea precedentă).

În cazul în care se efectuează modificări ale sistemului de operare care conduc la stări nefericite din care nu știm cum să ieșim, există întotdeauna posibilitatea de a reseta placa la setările inițiale și de a relua procesul de configurare de la început. Pentru resetarea plăcii la setările inițiale se va ține apăsat minim 20 de secunde butonul WiFi Reset.

9

O posibilă îmbunătățire a sistemului nostru este adăugarea unei antene WiFi externe pentru creșterea puterii semnalului. Placa are un conector special I-PEX pentru acest lucru dar utilizarea acestuia necesită dezlipirea de pe placă a unei rezistențe (imagine de mai jos).

10

ESP8266 Geolocation

Localizarea geografică este o problemă rezolvată cu ajutorul mai multor tehnologii actuale. Tehnologia GPS, cea mai cunoscută și utilizată modalitate de localizare, necesită funcționarea în spații deschise și utilizarea unui receptor specializat. În dispozitivele actuale această tehnologie se utilizează în combinație cu alte metode pentru a crește acuratețea localizării și pentru a oferi posibilitatea de localizare inclusiv în interiorul clădirilor. De exemplu, în telefoanele mobile inteligente, tehnologia GPS este combinată cu triangularizarea semnalelor radio GSM  și WiFi. În cadrul materialului de față vom arăta cum putem utiliza tehnica de localizare bazată pe triangularizarea semnalului WiFi utilizând o placă de dezvoltare WiFi ESP8266 și pe serviciul cloud Google Geolocation API. O astfel de soluție permite realizarea unui dispozitiv de localizare mult mai ieftin decât dispozitivele comerciale bazate pe soluții GPS și care permite localizarea inclusiv în interiorul clădirilor. Singura cerință de funcționare mai specială a dispozitivului este prezența unor rețele WiFi cartografiate de compania Google (cerință îndeplinită cu siguranță în mediul urban).

Pentru implementare am ales o placă de dezvoltare Adafruit Feather HUZZAH dar poate fi utilizată orice placă bazată pe ESP8266. Unul dintre avantajele oferite de placa de dezvoltare aleasă este posibilitatea de alimentare directă de la un acumulator LiPo de 3.7V permițând astfel realizarea unui sistem portabil. Pentru partea de afișare, utilă mai ales în cazul utilizării mobile a dispozitivului implementat, am utilizat un afișaj SHARP Memory Display ce are un consum extrem de redus (4µA @ 3.3V) și un contrast foarte bun.

Cele două componente ale sistemului vor comunica prin intermediul unei conexiuni SPI unidirecționale (doar 3 fire). Asftel, vom conecta:

  • Pinii 3.3V și GND al ecranului la pinii corespondenți ai plăcii de dezvoltare;
  • Pinul CLK al ecranului la pinul 14 al plăcii de dezvoltare;
  • Pinul DI al ecranului la pinul 13 al plăcii de dezvoltare;
  • Pinul CS al ecranului la pinul 5 al plăcii de dezvoltare.

2

Pinul 16 (Wake) al plăcii va fi conectat la pinul RST dacă dorim ca sistemul să intre în modul de consum redus între două localizări (util pentru funcționarea mobilă cu alimentare bazată pe acumulator). Conexiunea trebuie realizată după încărcarea programului pe placa de dezvoltare.

Programul sistemului a fost testat utilizând mediul de dezvoltare Arduino IDE 1.8.5 având instalate extensia ESP8266 Community 2.4.1 și bibliotecile Adafruit GFX 1.2.3, Adafruit SHARP Memory Display 1.0.6 (pentru controlul ecranului) și WifiLocation 1.2.2 (pentru interacțiunea cu Geolocation API).

#include <ESP8266WiFi.h>

#include <WifiLocation.h>

#include <Adafruit_GFX.h>

#include <Adafruit_SharpMem.h>

În cadrul programului trebuie personalizate datele de acces la o rețea WiFi (ssid și passwd) și cheia de acces la serviciile cloud Google (googleApiKey). Pentru a obține cheia de acces trebuie să vă înregistrați ca dezvoltator pe site-ul Google Developers, să activați funcționalitatea GeoLocation API și să solicitați cheia de acces. Accesul este gratuit până la o limită de 2500 de interogări pe zi (evitați o utilizare la un interval mai mic de 30 de secunde).

const char* googleApiKey = “…”;

const char* ssid = “…”;

const char* passwd = “…”;

WifiLocation location(googleApiKey);

#define SHARP_SCK  14

#define SHARP_MOSI 13

#define SHARP_SS   5

Adafruit_SharpMem display(SHARP_SCK, SHARP_MOSI, SHARP_SS, 96, 96);

#define BLACK 0

#define WHITE 1

Directiva debug poate fi utilizată (decomentată) dacă doriți să vedeți mesajele generate de sistem în consola serială.

//#define debug

3

În cadrul secțiunii setup() se va realiza scanarea rețelelor WiFi din zona în care se află sistemul, obținerea coordonatelor geografice de la serviciul cloud de localizare pe baza puterii semnalului fiecărei rețea WiFi observate și afișarea coordonatelor pe ecran (și în consola serială dacă este activată directiva debug). După un ciclu de localizare sistemul va intra în stare de consum redus (deepSleep) pentru 10 minute. Datele afișate vor conține latitudinea și longitudinea precum și acuratețea localizării (exprimată în metri).

4

void setup() {

#ifdef debug

Serial.begin(115200);

#endif

display.begin();

display.clearDisplay();

display.refresh();

WiFi.mode(WIFI_STA);

WiFi.begin(ssid, passwd);

while (WiFi.status() != WL_CONNECTED) {

#ifdef debug

Serial.print(“Attempting to connect to WPA SSID:“);

Serial.println(ssid);

Serial.print(“Status = “);

Serial.println(WiFi.status());

#endif

delay(500);

}

location_t loc = location.getGeoFromWiFi();

#ifdef debug

Serial.println(“Location request data”);

Serial.println(location.getSurroundingWiFiJson());

Serial.println(“Latitude: ” + String(loc.lat, 7));

Serial.println(“Longitude: ” + String(loc.lon, 7));

Serial.println(“Accuracy: ” + String(loc.accuracy));

#endif

display.setTextColor(BLACK);

display.setCursor(12,10);

display.setTextSize(1);

display.println(“Latitude:”);

display.setCursor(5,19);

display.setTextSize(2);

display.println(String(loc.lat, 3));

display.setCursor(12,37);

display.setTextSize(1);

display.println(“Longitude:”);

display.setCursor(5,46);

display.setTextSize(2);

display.println(String(loc.lon, 3));

display.setCursor(12,64);

display.setTextSize(1);

display.println(“Accuracy:”);

display.setCursor(5,73);

display.setTextSize(2);

display.println(String(loc.accuracy));

display.refresh();

ESP.deepSleep(600L*1000000L);

}

void loop() {

}

 

Cameră video GSM

Camerele de supraveghere video sunt deja o tehnologie comună. Ca urmare a creșterii acoperirii și vitezei de comunicație a rețelei Internet majoritatea camerelor de supraveghere sunt camere digitale IP. Instalarea acestora este simplă și este posibilă stocarea înregistrărilor video pe sisteme aflate la mare distanță. O categorie specială de sisteme de supraveghere video sunt camerele ce funcționează în lipsa unei infrastructuri Internet obișnuite (cablu sau WiFi). Este vorba de sistemele de supraveghere ce funcționează în locații izolate, camere de supraveghere a unor zone sălbatice, camere de supraveghere a vânatului etc. Aceste camere pot înregistra doar local imaginile surprinse (pe o memorie internă) sau le pot transmite prin intermediul infrastructurii puse la dispoziție de rețelele de telefonie mobilă ce au o acoperire mult mai mare decât rețelele WiFi / cablu. Materialul de față își propune să prezinte o modalitate de construire a unei astfel de camere video ce permite transmisia imaginilor la distanță prin intermediul unui modem GSM. Soluția este simplă și are un cost mult mai mic decât sistemele comerciale aflate pe piață. În construirea sistemului ne vom folosi de o placă Raspberry Pi Zero (este mai ieftină achiziționarea unui kit format din placă și adaptori decât achiziționarea separată, în cazul sistemului nostrul vom avea nevoie atât de pini cât și de adaptorul microUSB-USB), o cameră video Raspberry Pi versiunea 2 și de un modem GSM USB. Testele au fost realizate utilizând un modem USB Huawei E3131 oferit gratuit la contractarea oricărui alt serviciu de către unul dintre marile companii de servicii Internet și TV din România dar se poate utiliza orice modem USB (de exemplu). Unul dintre avantajele utilizării unui modem USB este posibilitatea utilizării rețelelor de telefonie mobilă exclusiv 3G / 4G.

2

Pentru alimentarea sistemului se poate utiliza o baterie externă USB sau un alimentator de rețea de 5V, minim 1A (se poate utiliza alimentatorul oficial al plăcii Raspberry Pi 3).

Conectarea camerei video necesită un cablu special deoarece conectorul de pe placa Raspberry Pi Zero are o dimensiune mai mică decât conectorul de pe placa Raspberry Pi.

4

ATENȚIE!!! Doar începând cu versiunea 1.3 placa Raspberry Pi Zero are conector CSI.

ATENȚIE!!! Conectorul CSI de pe placa Raspberry Pi Zero este foarte firav (mult mai firav decât cel de pe placa Raspberry Pi), manevrați cu foarte multă grijă sau riscați să distrugeți fizic clema de închidere a mufei.

3

Pentru punerea în funcțiune a sistemului mai aveți nevoie de un card microSD pe care să copiați sistemul de operare (se recomandă utilizarea unui card de memorie de calitate). Se recomandă utilizarea versiunii Lite a sistemului de operare Raspbian pentru a nu încărca microprocesorul cu execuția interfeței grafice utilizator și a altor servicii ce nu sunt necesare. Pentru testare s-a utilizat versiunea 2018-03-13-raspbian-stretch-lite.

Deoarece placa Raspberry Pi Zero nu are nici o conectivitate de rețea și nici nu are suficienți conectori pentru conectarea simultană a mai multor dispozitive USB (tastatură + modem GSM USB) se va apela la conectarea unui convertor serial – USB de 3.3V sau a unui cablu de debug Raspberry Pi. Această modalitate de acces va permite accesarea consolei de comenzi a plăcii direct prin intermediul conexiunii seriale USB. Pentru mai multe detalii se poate consulta și materialul „Raspberry Pi Zero Headless Quick Start”.

5

Funcționarea modemului GSM USB necesită câteva pachete software ce sunt în mod implicit instalate inclusiv în versiunea Lite a sistemului de operare Raspbian. În mod normal, după conectarea fizică a modemului, este necesară adăugării în fișierul /etc/network/interfaces a următoarelor linii:

auto gprs

iface gprs inet ppp

provider gprs

și crearea fișierului gprs în directorul /etc/ppp/peers cu următorul conținut:

connect “/usr/sbin/chat -v -f /etc/chatscripts/gprs -T em”

/dev/ttyUSB0

noipdefault

defaultroute

replacedefaultroute

hide-password

noauth

persist

usepeerdns

După o repornire a plăcii placa Raspberry Pi Zero ar trebui să aibă conectivitate Internet prin intermediul modemului GSM USB (bineînțeles dacă acesta are o cartelă SIM validă). În cazul în care configurația indicată nu funcționează este necesară conectarea temporară (înlocuirea modemului GSM USB) a unei plăci de rețea USB, aducerea la zi a sistemului de operare:

# sudo apt-get update

# sudo apt-get upgrade

și instalarea pachetelor ce deservesc funcționarea conexiunii de rețea prin intermediul modemului GSM USB:

# sudo apt-get install ppp usb-modeswitch usb-modeswitch-data

Alternativ, se poate utiliza o placă Raspberry Pi Zero W dacă nu se dorește realizarea unei camere video GSM ci a unei camere video IP WiFi (camera va transmite imagini prin intermediul unei rețele WiFi obișnuite). Varianta potrivită dacă doriți să realizați o cameră video de supraveghere pentru apartament nu pentru locații izolate. În acest caz kitul conține și cablul pentru conectorul CSI specific Raspberry Pi Zero și o carcasă în care se pot integra cu ușurință placa și camera video. Bineînțeles, este posibilă combinarea celor două soluții de conectare și se poate cerceta posibilitatea de realizare a unui router GSM-WiFi ce include cameră video de supraveghere.

Pentru verificarea funcționării camerei video se poate rula comanda:

# raspistill -o poza.jpg

Dacă comanda anterioară nu returnează nici o eroare, cel mai probabil camera video este conectată corect și funcționează corespunzător.

Pentru transmiterea în rețea a imaginilor preluate de la camera video vom utiliza programul motion iar ca interfață web motioneye. Pentru instalarea celor două programe se recomandă parcurgerea materialului oficial „Install On Raspbian”. Pachetul motion este integrat în distribuția Raspbian dar se recomandă instalarea versiunii indicate în materialul anterior. Camera CSI utilizată în proiectul nostru nu este compatibilă cu software-ul motion din acest motiv trebuie activat un modul la nivel de kernel care să permită utilizarea acesteia ca o cameră USB obișnuită. Acest lucru se realizează prin inserarea următoarei linii în fișierul /etc/modules:

bcm2835-v4l2

Dacă utilizăm o placă Raspberry Pi Zero W putem verifica funcționarea transmiterii de imagini în rețeaua locală accesând adresa IP a plăcii pe portul 8765 (utilizator: admin, fără nici un fel de parolă).

În cazul în care utilizăm Raspberry Pi Zero și modem USB GSM sau în cazul în care dorim să accesăm o placă Raspberry Pi Zero W dintr-o altă rețea decât cea locală, adică dacă dorim să accesăm interfața MotionEye prin Internet, vom utiliza un serviciu ce permite redirectarea conexiunilor. Acest serviciu este disponibil prin intermediul platformei remot3.it și este gratuit (prin înregistrarea unui cont) la un nivel decent de utilizare (8 ore pe zi). Această soluție ne scutește de configurații de rețea complicate precum redirectare de porturi sau achiziționarea de adrese IP fixe de la furnizorul de servicii Internet. Pentru utilizarea efectivă a serviciului este necesară instalarea pachetului weavedconnectd și înregistrarea sistemului sub contul creat pe platformă – procese detaliate în materialul „Installing the remot3.it weavedconnectd daemon on your Raspberry Pi”. În cadrul instalării este necesară definirea unei redirectări pentru interfața web MotionEye (protocol HTTP, port 8765):

6

După parcurgerea acestor operații vom putea accesa interfața web a camerei video de oriunde din Internet prin intermediul platformei remot3.it.

7

O alternativă suplimentară de acces la interfața web a camerei este aplicația mobilă (pentru sistemul de operare Android) Weaved For Raspberry Pi prin intermediul căreia veți putea accesa de la distanță orice serviciu de pe placa Raspberry Pi inclusiv interfața web a camerei video.

8